blob: c1e394d9b3e4f827155c64dedf3f7aada234123a [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Python library for displaying tabular data in a ASCII table format"
2HOMEPAGE = "http://code.google.com/p/prettytable"
3LICENSE = "BSD-3-Clause"
Andrew Geissler220dafd2023-10-04 10:18:08 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=c9a6829fcd174d9535b46211917c7671"
Patrick Williams92b42cb2022-09-03 06:53:57 -05005
Andrew Geissler220dafd2023-10-04 10:18:08 -05006SRC_URI[sha256sum] = "f4ed94803c23073a90620b201965e5dc0bccf1760b7a7eaf3158cab8aaffdf34"
Patrick Williams92b42cb2022-09-03 06:53:57 -05007
8do_install:append() {
9 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
10 for f in $perm_files; do
11 chmod 644 "${f}"
12 done
13}
14
Patrick Williams92b42cb2022-09-03 06:53:57 -050015BBCLASSEXTEND = "native nativesdk"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060016inherit pypi ptest python_hatchling
Patrick Williams92b42cb2022-09-03 06:53:57 -050017
18SRC_URI += " \
19 file://run-ptest \
20"
21
Andrew Geisslerc5535c92023-01-27 16:10:19 -060022DEPENDS += "\
23 ${PYTHON_PN}-hatch-vcs-native \
24"
Patrick Williams92b42cb2022-09-03 06:53:57 -050025
26RDEPENDS:${PN} += " \
27 ${PYTHON_PN}-math \
28 ${PYTHON_PN}-html \
29 ${PYTHON_PN}-wcwidth \
30 ${PYTHON_PN}-json \
31 ${PYTHON_PN}-compression \
32 ${PYTHON_PN}-importlib-metadata \
33"
34
35RDEPENDS:${PN}-ptest += " \
36 ${PYTHON_PN}-pytest \
37 ${PYTHON_PN}-pytest-lazy-fixture \
38 ${PYTHON_PN}-sqlite3 \
39"
40
41do_install_ptest() {
42 cp -f ${S}/tests/test_prettytable.py ${D}${PTEST_PATH}/
43}