Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "JSON Web Token implementation in Python" |
| 2 | DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\ |
| 3 | Original implementation was written by https://github.com/progrium" |
| 4 | HOMEPAGE = "http://github.com/jpadilla/pyjwt" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e4b56d2c9973d8cf54655555be06e551" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "57e28d156e3d5c10088e0c68abb90bfac3df82b40a71bd0daa20c65ccd5c23de" |
| 9 | |
| 10 | PYPI_PACKAGE = "PyJWT" |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | RDEPENDS:${PN} = " \ |
| 14 | python3-json \ |
| 15 | python3-cryptography \ |
| 16 | " |
| 17 | |
| 18 | BBCLASSEXTEND = "native nativesdk" |