Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Telepathy IRC connection manager" |
| 2 | DESCRIPTION = "Telepathy implementation of the Internet Relay Chat protocols." |
| 3 | HOMEPAGE = "http://telepathy.freedesktop.org/wiki/" |
| 4 | DEPENDS = "glib-2.0 dbus telepathy-glib openssl libxslt-native" |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 7 | file://src/idle.c;beginline=1;endline=19;md5=b06b1e2594423111a1a7910b0eefc7f9" |
| 8 | |
| 9 | SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ |
| 10 | file://fix-svc-gtk-doc.h-target.patch" |
| 11 | SRC_URI[md5sum] = "92a2de5198284cbd3c430b0d1a971a86" |
| 12 | SRC_URI[sha256sum] = "3013ad4b38d14ee630b8cc8ada5e95ccaa849b9a6fe15d2eaf6d0717d76f2fab" |
| 13 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | inherit autotools pkgconfig ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)} |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 15 | |
| 16 | FILES_${PN} += "${datadir}/telepathy \ |
| 17 | ${datadir}/dbus-1" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | python() { |
| 20 | if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split(): |
| 21 | raise bb.parse.SkipRecipe('Requires meta-python2 to be present.') |
| 22 | } |