Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | # Copyright (C) 2022 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Library to parse raw trace event formats " |
| 5 | HOMEPAGE = "https://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git/" |
| 6 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \ |
| 8 | file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd" |
| 9 | SECTION = "libs" |
| 10 | DEPENDS = "libtraceevent bison-native flex-native" |
| 11 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 12 | SRCREV = "aebab37379d0fbadc702d64aca0fe5cf18676404" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 13 | SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git;branch=${BPN};protocol=https \ |
| 14 | file://0001-makefile-Do-not-preserve-ownership-in-cp-command.patch \ |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 15 | file://0001-tracefs-perf-Add-missing-headers-for-syscall-and-SYS.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | " |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit pkgconfig |
| 20 | |
| 21 | do_install() { |
| 22 | oe_runmake install DESTDIR=${D} pkgconfig_dir=${libdir}/pkgconfig |
| 23 | } |