blob: a48195a15d0b446c932354f352e2eafa14edbc4a [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "[Boost::ext].SML (State Machine Language)"
2DESCRIPTION = "Your scalable C++14 one header only State Machine Library with no dependencies"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00003HOMEPAGE = "https://github.com/boost-ext/sml"
4BUGTRACKER = "https://github.com/boost-ext/sml/issues"
5SECTION = "libs"
6LICENSE = "BSL-1.0"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=e4224ccaecb14d942c71d31bef20d78c"
8
9DEPENDS += "boost qemu-native"
10
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011SRC_URI = "git://github.com/boost-ext/sml.git;protocol=https;branch=master"
Patrick Williams03514f12024-04-05 07:04:11 -050012SRCREV = "b7df6180d20422b2724d26007aebb24066f2a6a9"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18# Building benchmarks takes a lot of time and requires additional headers (euml2.hpp)
Patrick Williams03907ee2022-05-01 06:28:52 -050019# Building examples fail with gcc-12
20EXTRA_OECMAKE:append = " -DSML_BUILD_BENCHMARKS:bool=OFF -DSML_BUILD_EXAMPLES=OFF"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000021
22# [boost::ext].XML is a header only C++ library, so the main package will be empty.
23ALLOW_EMPTY:${PN} = "1"
24
25BBCLASSEXTEND = "nativesdk"