Andrew Geissler | 26e4bea | 2020-11-30 19:54:03 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Closed source binary files to help boot all raspberry pi devices." |
| 2 | LICENSE = "Broadcom-RPi" |
| 3 | |
| 4 | LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=c403841ff2837657b2ed8e5bb474ac8d" |
| 5 | |
| 6 | inherit deploy nopackages |
| 7 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 8 | RPIFW_DATE ?= "20240319" |
| 9 | SRCREV = "9f24f4bc2bdd07ffd158cfbb4bce88a2efc4c1f5" |
| 10 | SHORTREV = "${@d.getVar("SRCREV", False).__str__()[:7]}" |
| 11 | RPIFW_SRC_URI ?= "https://api.github.com/repos/raspberrypi/firmware/tarball/9f24f4bc2bdd07ffd158cfbb4bce88a2efc4c1f5;downloadfilename=raspberrypi-firmware-${SHORTREV}.tar.gz" |
| 12 | RPIFW_S ?= "${WORKDIR}/raspberrypi-firmware-${SHORTREV}" |
| 13 | |
| 14 | SRC_URI = "${RPIFW_SRC_URI}" |
| 15 | SRC_URI[sha256sum] = "4b436f8946b139c6a1202375ef55d4848e3bcd8c1a9cb47000e06d7ecec828f7" |
| 16 | |
| 17 | PV = "${RPIFW_DATE}" |
Andrew Geissler | 26e4bea | 2020-11-30 19:54:03 -0600 | [diff] [blame] | 18 | |
| 19 | INHIBIT_DEFAULT_DEPS = "1" |
| 20 | |
| 21 | DEPENDS = "rpi-config rpi-cmdline" |
| 22 | |
| 23 | COMPATIBLE_MACHINE = "^rpi$" |
| 24 | |
| 25 | S = "${RPIFW_S}/boot" |
| 26 | |
| 27 | PR = "r3" |
| 28 | |
| 29 | do_deploy() { |
| 30 | install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} |
| 31 | |
| 32 | for i in ${S}/*.elf ; do |
| 33 | cp $i ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} |
| 34 | done |
| 35 | for i in ${S}/*.dat ; do |
| 36 | cp $i ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} |
| 37 | done |
| 38 | for i in ${S}/*.bin ; do |
| 39 | cp $i ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} |
| 40 | done |
| 41 | |
| 42 | # Add stamp in deploy directory |
| 43 | touch ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/${PN}-${PV}.stamp |
| 44 | } |
| 45 | |
| 46 | do_deploy[depends] += "rpi-config:do_deploy rpi-cmdline:do_deploy" |
| 47 | |
| 48 | addtask deploy before do_build after do_install |
| 49 | do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}" |
| 50 | |
| 51 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 52 | |