blob: b126bfc8cb7b11df606b3f1bb9f91052cc4d32b3 [file] [log] [blame]
Lancelot Kao4357d532021-02-22 15:20:35 -06001SUMMARY = "Phosphor OpenBMC Kudo BIOS Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC Kudo BIOS Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
13RDEPENDS_${PN} += "libsystemd"
14RDEPENDS_${PN} += "bash"
15
16FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json"
17
18SRC_URI_append_kudo = " \
19 file://phosphor-ipmi-flash-bios-update.service \
20 file://config-bios.json \
21 "
22
23SYSTEMD_PACKAGES = "${PN}"
24SYSTEMD_SERVICE_${PN}_append_kudo = " \
25 phosphor-ipmi-flash-bios-update.service \
26 "
27
28do_install () {
29 install -d ${D}${datadir}/phosphor-ipmi-flash
30 install -m 0644 ${WORKDIR}/config-bios.json ${D}${datadir}/phosphor-ipmi-flash
31 install -d ${D}${systemd_system_unitdir}
32 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service ${D}${systemd_system_unitdir}
33}