Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "netkit-rusers includes rusers - Displays who is logged in to machines on local network \ |
| 2 | rusersd - Logged in users server" |
| 3 | HOMEPAGE = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit" |
| 4 | SECTION = "net" |
| 5 | LICENSE = "BSD" |
| 6 | LIC_FILES_CHKSUM = "file://rusers/rusers.c;beginline=2;endline=3;md5=f4fc634a4ce8c569911196b72b10770e" |
| 7 | DEPENDS = " tcp-wrappers libtirpc rpcbind" |
| 8 | |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 9 | SRC_URI = "http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz;name=archive \ |
| 10 | http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}-8.diff.gz;name=patch8 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | file://rpc.rusersd-Makefile-fix-parallel-build-issue.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | file://0001-Link-with-libtirpc.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | " |
| 14 | |
| 15 | SRC_URI[archive.md5sum] = "dc99a80b9fde2ab427c874f88f1c1602" |
| 16 | SRC_URI[archive.sha256sum] = "f00138651865ad2dcfec5dedda0cda403cb80c4ab68efcc3bbccafe198c24b6d" |
| 17 | SRC_URI[patch8.md5sum] = "1ff498113e0f920d92088092e5570bdc" |
| 18 | SRC_URI[patch8.sha256sum] = "14882dbdda4e37baa84d55b54b46c7e063a20fc9e04d1be1a2807643cd0f3067" |
| 19 | |
| 20 | inherit autotools-brokensep |
| 21 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" |
| 23 | LIBS += "-ltirpc" |
| 24 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 25 | do_configure () { |
| 26 | ./configure --prefix=${prefix} |
| 27 | echo "LDFLAGS=${LDFLAGS}" >> MCONFIG |
| 28 | echo "USE_GLIBC=1" >> MCONFIG |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | echo "LIBS=${LIBS}" >> MCONFIG |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 30 | } |
| 31 | |
| 32 | do_install () { |
| 33 | install -d ${D}${bindir} |
| 34 | install -d ${D}${sbindir} |
| 35 | install -d ${D}${mandir}/man1 |
| 36 | install -d ${D}${mandir}/man8 |
| 37 | install -d ${D}${sysconfdir}/xinetd.d |
| 38 | |
| 39 | sed -i 's/install -s/install/' rusers/Makefile |
| 40 | sed -i 's/install -s/install/' rup/Makefile |
| 41 | sed -i 's/install -s/install/' rpc.rusersd/Makefile |
| 42 | |
| 43 | oe_runmake 'INSTALLROOT=${D}' 'BINMODE=0755' \ |
| 44 | 'DAEMONMODE=0755' 'MANMODE=0644' \ |
| 45 | 'BINDIR=${bindir}' 'SBINDIR=${sbindir}' \ |
| 46 | 'MANDIR=${mandir}' install |
| 47 | |
| 48 | # create the xinetd config file |
| 49 | cat >rusersd.conf <<EOF |
| 50 | service rusersd |
| 51 | { |
| 52 | disable = yes |
| 53 | type = RPC |
| 54 | rpc_version = 1-2 |
| 55 | socket_type = dgram |
| 56 | protocol = udp |
| 57 | wait = yes |
| 58 | user = root |
| 59 | server = ${sbindir}/rpc.rusersd |
| 60 | } |
| 61 | EOF |
| 62 | install rusersd.conf ${D}/${sysconfdir}/xinetd.d/rusersd |
| 63 | } |
| 64 | |
| 65 | |
| 66 | INSANE_SKIP_${PN} = "already-stripped" |
| 67 | |
| 68 | PACKAGES = "${PN}-client ${PN}-server ${PN}-doc ${BPN}-dbg" |
| 69 | FILES_${PN}-client = "${bindir}/*" |
| 70 | FILES_${PN}-server = "${sbindir}/* ${sysconfdir}" |
| 71 | FILES_${PN}-doc = "${mandir}" |
| 72 | FILES_${PN}-dbg = "${prefix}/src/debug \ |
| 73 | ${bindir}/.debug ${sbindir}/.debug" |
| 74 | |
| 75 | RDEPENDS_${PN}-server = "tcp-wrappers xinetd rpcbind" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 76 | |
| 77 | # http://errors.yoctoproject.org/Errors/Details/186962/ |
| 78 | EXCLUDE_FROM_WORLD_libc-musl = "1" |