Lancelot Kao | 180fdfc | 2021-02-22 17:30:02 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Kudo SCP Firmware Upgrade Command" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Kudo SCP Firmware Upgrade Comman Daemon" |
Lancelot Kao | 180fdfc | 2021-02-22 17:30:02 -0600 | [diff] [blame] | 3 | |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | inherit obmc-phosphor-systemd |
| 10 | |
| 11 | DEPENDS += "systemd" |
| 12 | DEPENDS += "phosphor-ipmi-flash" |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame] | 13 | RDEPENDS:${PN} += "libsystemd" |
| 14 | RDEPENDS:${PN} += "bash" |
Lancelot Kao | 180fdfc | 2021-02-22 17:30:02 -0600 | [diff] [blame] | 15 | |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame] | 16 | FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-scp.json" |
| 17 | FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-scpback.json" |
Lancelot Kao | 180fdfc | 2021-02-22 17:30:02 -0600 | [diff] [blame] | 18 | |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame] | 19 | SRC_URI:append:kudo = " \ |
Lancelot Kao | 180fdfc | 2021-02-22 17:30:02 -0600 | [diff] [blame] | 20 | file://phosphor-ipmi-flash-scp-update.service \ |
| 21 | file://phosphor-ipmi-flash-scpback-update.service \ |
| 22 | file://config-scp.json \ |
| 23 | file://config-scpback.json \ |
| 24 | " |
| 25 | |
| 26 | SYSTEMD_PACKAGES = "${PN}" |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame] | 27 | SYSTEMD_SERVICE:${PN}:append:kudo = " \ |
Lancelot Kao | 180fdfc | 2021-02-22 17:30:02 -0600 | [diff] [blame] | 28 | phosphor-ipmi-flash-scp-update.service \ |
| 29 | phosphor-ipmi-flash-scpback-update.service \ |
| 30 | " |
| 31 | |
| 32 | do_install () { |
| 33 | install -d ${D}${datadir}/phosphor-ipmi-flash |
| 34 | install -m 0644 ${WORKDIR}/config-scp.json ${D}${datadir}/phosphor-ipmi-flash |
| 35 | install -m 0644 ${WORKDIR}/config-scpback.json ${D}${datadir}/phosphor-ipmi-flash |
| 36 | |
| 37 | install -d ${D}${systemd_system_unitdir} |
| 38 | install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-scp-update.service ${D}${systemd_system_unitdir} |
| 39 | install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-scpback-update.service ${D}${systemd_system_unitdir} |
| 40 | } |