Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \ |
| 2 | safe memory reclamation mechanisms and non-blocking data structures \ |
| 3 | designed to aid in the design and implementation of high performance \ |
| 4 | concurrent systems." |
| 5 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 6 | LICENSE = "BSD-2-Clause & Apache-2.0" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 7 | HOMEPAGE = "http://concurrencykit.org" |
| 8 | SECTION = "base" |
| 9 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | PV = "0.7.0+git${SRCPV}" |
| 11 | SRCREV = "6e8e5bec2e2f8cef2072a68579cbb07ababf3331" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a0b24c1a8f9ad516a297d055b0294231" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 14 | file://0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch \ |
| 15 | file://0001-build-Use-ilp32d-abi-on-riscv32-and-lp64d-on-rv64.patch" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64|riscv32|riscv64).*-linux*" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | |
| 21 | inherit autotools-brokensep |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | PLAT:powerpc64 = "ppc64" |
| 24 | PLAT:powerpc64le = "ppc64" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 25 | PLAT:riscv32 = "riscv" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | PLAT ?= "${HOST_ARCH}" |
| 27 | |
| 28 | do_configure () { |
| 29 | export PLATFORM=${PLAT} |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 30 | ${S}/configure \ |
| 31 | --prefix=${prefix} \ |
| 32 | --includedir=${includedir} \ |
| 33 | --libdir=${libdir} |
| 34 | } |
| 35 | |
| 36 | do_compile () { |
| 37 | oe_runmake |
| 38 | } |
| 39 | |
| 40 | do_install () { |
| 41 | oe_runmake 'DESTDIR=${D}' install |
| 42 | } |