blob: 0ee53afb6d6a4ab972833e2a6a2512d53a7b3153 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Desktop containment framework."
2HOMEPAGE = "http://flatpak.org"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRC_URI = " \
7 gitsm://github.com/flatpak/flatpak;protocol=https;branch=main \
8 file://0001-flatpak-pc-add-pc_sysrootdir.patch \
9 file://0001-meson.build-require-for-native-wayland-scanner.patch \
10"
11
12SRCREV = "27b11b93c2a80a91c9461bc6c7f5e9a201406041"
13
14S = "${WORKDIR}/git"
15
16inherit meson pkgconfig gettext systemd gtk-doc gobject-introspection python3native useradd mime features_check
17
18REQUIRED_DISTRO_FEATURES = "polkit"
19
20DEPENDS = " \
21 appstream \
22 bison-native \
23 dconf \
24 fuse3 \
25 gdk-pixbuf \
26 glib-2.0 \
27 gpgme \
28 json-glib \
29 libarchive \
30 libcap \
31 libxml2 \
32 ostree \
33 polkit \
34 python3-pyparsing-native \
35 zstd \
36"
37
38RDEPENDS:${PN} = " \
39 bubblewrap \
40 ca-certificates \
41 dconf \
42 flatpak-xdg-utils \
43 xdg-dbus-proxy \
44"
45
46EXTRA_OEMESON += "-Dsystem_dbus_proxy=${bindir}/xdg-dbus-proxy -Dsystem_bubblewrap=${bindir}/bwrap"
47
48GIR_MESON_OPTION = "gir"
49GIR_MESON_ENABLE_FLAG = 'enabled'
50GIR_MESON_DISABLE_FLAG = 'disabled'
51GTKDOC_MESON_OPTION = 'gtkdoc'
52GTKDOC_MESON_ENABLE_FLAG = 'enabled'
53GTKDOC_MESON_DISABLE_FLAG = 'disabled'
54
55PACKAGECONFIG[curl] = "-Dhttp_backend=curl,,curl"
56PACKAGECONFIG[docbook_docs] = "-Ddocbook_docs=enabled,-Ddocbook_docs=disabled,xmlto-native"
57PACKAGECONFIG[man] = "-Dman=enabled,-Dman=disabled,libxslt-native"
58PACKAGECONFIG[soup] = "-Dhttp_backend=soup,,libsoup-2.4"
59PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,xauth socat-native"
60PACKAGECONFIG[xauth] = "-Dxauth=enabled,-Dxauth=disabled,xauth"
61PACKAGECONFIG[seccomp] = "-Dseccomp=enabled,-Dseccomp=disabled,libseccomp"
62PACKAGECONFIG[selinux] = "-Dselinux_module=enabled,-Dselinux_module=disabled,libselinux"
63PACKAGECONFIG[wayland-security-context] = "-Dwayland_security_context=enabled,-Dwayland_security_context=disabled,wayland wayland-native wayland-protocols"
64
65PACKAGECONFIG ?= " \
66 curl \
67 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xauth', '', d)} \
68 ${@bb.utils.contains('DISTRO_FEATURES', 'seccomp', 'seccomp', '', d)} \
69 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-security-context', '', d)} \
70"
71
72FILES:${PN} += "${libdir} ${datadir}"
73
74USERADD_PACKAGES = "${PN}"
75USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd"
76
77do_install:append() {
78 chmod 0700 ${D}/${datadir}/polkit-1/rules.d
79 chown polkitd ${D}/${datadir}/polkit-1/rules.d
80 chgrp root ${D}/${datadir}/polkit-1/rules.d
81}