blob: 8c75f936de60cc3b404d3229d074e6eecab0b68e [file] [log] [blame]
Andre McCurdy1ea3f662016-12-15 06:11:31 -08001DESCRIPTION = "Google's framework for writing C++ tests"
Brad Bishop26bdd442019-08-16 17:08:17 -04002HOMEPAGE = "https://github.com/google/googletest"
Andre McCurdy1ea3f662016-12-15 06:11:31 -08003SECTION = "libs"
4LICENSE = "BSD-3-Clause"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07005LIC_FILES_CHKSUM = "file://LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
Andre McCurdy1ea3f662016-12-15 06:11:31 -08006
Brad Bishop26bdd442019-08-16 17:08:17 -04007PROVIDES += "gmock gtest"
Andre McCurdy1ea3f662016-12-15 06:11:31 -08008
Brad Bishop316dfdd2018-06-25 12:45:53 -04009S = "${WORKDIR}/git"
Andrew Geissler5082cc72023-09-11 08:41:39 -040010SRCREV = "f8d7d77c06936315286eb55f8de22cd23c188571"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050011SRC_URI = "git://github.com/google/googletest.git;branch=main;protocol=https"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080012
Andre McCurdy1ea3f662016-12-15 06:11:31 -080013inherit cmake
14
Patrick Williams213cb262021-08-07 19:21:33 -050015ALLOW_EMPTY:${PN} = "1"
16ALLOW_EMPTY:${PN}-dbg = "1"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080017
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN}-dev += "${PN}-staticdev"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080019
20BBCLASSEXTEND = "native nativesdk"
Brad Bishope42b3e32020-01-15 22:08:42 -050021
Patrick Williams213cb262021-08-07 19:21:33 -050022do_configure:prepend() {
Brad Bishope42b3e32020-01-15 22:08:42 -050023 # explicitly use python3
24 # the scripts are already python3 compatible since https://github.com/google/googletest/commit/d404af0d987a9c38cafce82a7e26ec8468c88361 and other fixes like this
25 # but since this oe-core change http://git.openembedded.org/openembedded-core/commit/?id=5f8f16b17f66966ae91aeabc23e97de5ecd17447
26 # there isn't python in HOSTTOOLS so "env python" fails
Patrick Williams58776372022-04-13 09:07:35 -050027 sed -i 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@g' ${S}/googlemock/test/*py ${S}/googletest/test/*py
Brad Bishope42b3e32020-01-15 22:08:42 -050028}