Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Keyboard configuration database for X Window" |
| 2 | |
| 3 | DESCRIPTION = "The non-arch keyboard configuration database for X \ |
| 4 | Window. The goal is to provide the consistent, well-structured, \ |
| 5 | frequently released open source of X keyboard configuration data for X \ |
| 6 | Window System implementations. The project is targeted to XKB-based \ |
| 7 | systems." |
| 8 | |
| 9 | HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig" |
| 10 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config" |
| 11 | |
| 12 | LICENSE = "MIT & MIT" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=8fc8ae699974c360e2e2e883a63ce264" |
| 14 | |
| 15 | SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.xz" |
| 16 | SRC_URI[sha256sum] = "7a3dba1bec7dc7191432da021242d17c9cf6c89690e6c57b0de048ff8c9d2ae3" |
| 17 | |
| 18 | SECTION = "x11/libs" |
| 19 | DEPENDS = "util-macros libxslt-native" |
| 20 | |
| 21 | EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps" |
| 22 | |
| 23 | FILES:${PN} += "${datadir}/X11/xkb" |
| 24 | |
| 25 | inherit meson pkgconfig gettext python3native |
| 26 | |
| 27 | do_install:append () { |
| 28 | install -d ${D}${datadir}/X11/xkb/compiled |
| 29 | cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND += "native" |