blob: 0086eae5c3f1269549f1074504ad525cc1fdcc1a [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Lightweight and flexible command-line JSON processor"
2DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \
3 filter and map and transform structured data with the same \
4 ease that sed, awk, grep and friends let you play with text."
5HOMEPAGE = "https://stedolan.github.io/jq/"
6BUGTRACKER = "https://github.com/stedolan/jq/issues"
7SECTION = "utils"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=15d03e360fa7399f76d5a4359fc72cbf"
10
11SRC_URI = "https://github.com/stedolan/${BPN}/releases/download/${BP}/${BP}.tar.gz \
12"
13
14SRC_URI[md5sum] = "e68fbd6a992e36f1ac48c99bbf825d6b"
15SRC_URI[sha256sum] = "5de8c8e29aaa3fb9cc6b47bb27299f271354ebb72514e3accadc7d38b5bbaa72"
16
17inherit autotools-brokensep
18
19PACKAGECONFIG ?= "oniguruma"
20
21PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native"
22PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native"
23PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig"
24
25OE_EXTRACONF += " \
26 --disable-valgrind \
27"
28
29BBCLASSEXTEND = "native"