blob: c27cd1d68ad7476a067c009166d64bdd5bee77c7 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Pure-Python RSA implementation"
2SECTION = "devel/python"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c403f6882d4f97a9cd927df987d55634"
5
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05006SRC_URI[sha256sum] = "e38464a49c6c85d7f1351b0126661487a7e0a14a50f1675ec50eb34d4f20ef21"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
Andrew Geissler9aee5002022-03-30 16:27:02 +00008inherit pypi python_poetry_core update-alternatives
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10ALTERNATIVE:${PN} = "\
11 pyrsa-decrypt \
12 pyrsa-encrypt \
13 pyrsa-keygen \
14 pyrsa-priv2pub \
15 pyrsa-sign \
16 pyrsa-verify \
17"
18
19ALTERNATIVE_LINK_NAME[pyrsa-decrypt] = "${bindir}/pyrsa-decrypt"
20ALTERNATIVE_LINK_NAME[pyrsa-encrypt] = "${bindir}/pyrsa-encrypt"
21ALTERNATIVE_LINK_NAME[pyrsa-keygen] = "${bindir}/pyrsa-keygen"
22ALTERNATIVE_LINK_NAME[pyrsa-priv2pub] = "${bindir}/pyrsa-priv2pub"
23ALTERNATIVE_LINK_NAME[pyrsa-sign] = "${bindir}/pyrsa-sign"
24ALTERNATIVE_LINK_NAME[pyrsa-verify] = "${bindir}/pyrsa-verify"
25ALTERNATIVE_PRIORITY = "30"
26
27
28RDEPENDS:${PN} += "\
Patrick Williams39653562024-03-01 08:54:02 -060029 python3-compression \
30 python3-crypt \
31 python3-doctest \
32 python3-logging \
33 python3-math \
34 python3-multiprocessing \
35 python3-netclient \
36 python3-pickle \
Andrew Geissler595f6302022-01-24 19:11:47 +000037"
38
Patrick Williams39653562024-03-01 08:54:02 -060039RDEPENDS:${PN} += "python3-pyasn1"