Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Python Data Validation for Humans" |
| 2 | HOMEPAGE = "https://python-validators.github.io/validators" |
| 3 | LICENSE = "MIT" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b3fb4b9e6db86c69a33d5e3ee013ab59" |
| 6 | SRC_URI[sha256sum] = "cd23defb36de42d14e7559cf0757f761bb46b10d9de2998e6ef805f769d859e3" |
| 7 | |
| 8 | inherit pypi python_setuptools_build_meta ptest |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN}-ptest += " \ |
| 15 | python3-pytest \ |
| 16 | python3-unittest-automake-output \ |
| 17 | " |
| 18 | |
| 19 | do_install_ptest() { |
| 20 | install -d ${D}${PTEST_PATH}/tests |
| 21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 22 | } |
| 23 | |
| 24 | RDEPENDS:${PN} += " \ |
| 25 | python3-crypt \ |
| 26 | python3-datetime \ |
| 27 | python3-netclient \ |
| 28 | " |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |