Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Yet Another Flash File System" |
| 2 | DESCRIPTION = "Tools for managing 'yaffs2' file systems." |
| 3 | |
| 4 | SECTION = "base" |
| 5 | HOMEPAGE = "http://www.yaffs.net" |
| 6 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | LICENSE = "GPL-2.0-only" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=11;endline=13;md5=5f5464f9b3e981ca574e65b00e438561 \ |
| 9 | file://utils/mkyaffsimage.c;beginline=10;endline=12;md5=5f5464f9b3e981ca574e65b00e438561 \ |
| 10 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 12 | # The commit date of SRCREV |
| 13 | PV = "20221209" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | |
| 15 | DEPENDS = "mtd-utils" |
| 16 | |
| 17 | # Source is the HEAD of master branch at the time of writing this recipe |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 18 | SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master \ |
| 19 | file://makefile-add-ldflags.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | file://0001-define-loff_t-if-not-already-defined.patch \ |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 21 | file://0001-yaffs_guts.h-define-YTIME_T-if-not-already-defined.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 22 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 23 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 24 | SRCREV = "613a901a229e8a701c18f003dd0aee18453e0670" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | |
| 26 | UPSTREAM_CHECK_COMMITS = "1" |
| 27 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 28 | S = "${WORKDIR}/git" |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | CFLAGS:append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 31 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 32 | |
| 33 | do_compile() { |
| 34 | cd utils && oe_runmake |
| 35 | } |
| 36 | |
| 37 | INSTALL_FILES = "mkyaffsimage \ |
| 38 | mkyaffs2image \ |
| 39 | " |
| 40 | do_install() { |
| 41 | install -d ${D}${sbindir}/ |
| 42 | for i in ${INSTALL_FILES}; do |
| 43 | install -m 0755 utils/$i ${D}${sbindir}/ |
| 44 | done |
| 45 | } |
| 46 | |
| 47 | BBCLASSEXTEND = "native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 48 | |
| 49 | # Fixed make clean error: |
| 50 | #make -C /lib/modules/4.4.0-112-generic/build M=<snip> |
| 51 | #make: *** /lib/modules/4.4.0-112-generic/build: No such file or directory. Stop. |
| 52 | #make: *** [clean] Error 2 |
| 53 | CLEANBROKEN = "1" |