blob: 1c49d891d2e0986fe2c6a8ea058d88b289811fab [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables."
2HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
5
Patrick Williams2a254922023-08-11 09:48:11 -05006SRC_URI[sha256sum] = "e7067471884de5478c58a511e529f0f9bd1c66bfef1dea90935438d6c23306d1"
Andrew Geisslereff27472021-10-29 15:35:00 -05007
8PYPI_PACKAGE = "ConfigArgParse"
9
10inherit pypi setuptools3
11
12PACKAGECONFIG ?= "yaml"
Patrick Williams39653562024-03-01 08:54:02 -060013PACKAGECONFIG[yaml] = ",,,python3-pyyaml"
Andrew Geisslereff27472021-10-29 15:35:00 -050014
15RDEPENDS:${PN} += "\
Patrick Williams39653562024-03-01 08:54:02 -060016 python3-core \
17 python3-shell \
18 python3-json \
Andrew Geisslereff27472021-10-29 15:35:00 -050019"
20
21BBCLASSEXTEND = "native nativesdk"