Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Google Authentication Library" |
| 2 | HOMEPAGE = "https://github.com/googleapis/google-auth-library-python" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 5 | |
| 6 | inherit pypi setuptools3 ptest |
| 7 | |
| 8 | SRC_URI[sha256sum] = "672dff332d073227550ffc7457868ac4218d6c500b155fe6cc17d2b13602c360" |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN}-ptest += " \ |
| 15 | python3-cryptography \ |
| 16 | python3-flask \ |
| 17 | python3-freezegun \ |
| 18 | python3-grpcio \ |
| 19 | python3-mock \ |
| 20 | python3-oauth2client \ |
| 21 | python3-pyopenssl \ |
| 22 | python3-pytest \ |
| 23 | python3-pytest-localserver \ |
| 24 | python3-pyu2f \ |
| 25 | python3-requests \ |
| 26 | python3-responses \ |
| 27 | python3-unittest-automake-output \ |
| 28 | python3-unixadmin \ |
| 29 | " |
| 30 | |
| 31 | do_install_ptest() { |
| 32 | install -d ${D}${PTEST_PATH}/tests |
| 33 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 34 | } |
| 35 | |
| 36 | RDEPENDS:${PN} += "\ |
| 37 | python3-cachetools \ |
| 38 | python3-json \ |
| 39 | python3-pyasn1-modules \ |
| 40 | python3-rsa \ |
| 41 | " |