Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Python bindings for libgpiod." |
| 2 | |
| 3 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & CC-BY-SA-4.0" |
| 4 | # The actual license files live in the upstream libgpiod from which the pypi |
| 5 | # package is spun out. |
| 6 | LIC_FILES_CHKSUM = "file://setup.py;beginline=237;endline=237;md5=f5ddb56912b7f20bf94aa4d1bdcd3533" |
| 7 | |
| 8 | SRC_URI += "file://run-ptest" |
| 9 | |
| 10 | SRC_URI[sha256sum] = "a33193d6cab79d252329f71666a35a3668e04f1f82bf9b93ee2c9ae852398b20" |
| 11 | |
| 12 | inherit setuptools3-base python_pep517 ptest pypi |
| 13 | |
| 14 | DEPENDS += " \ |
| 15 | libgpiod \ |
| 16 | python3-setuptools-native \ |
| 17 | " |
| 18 | RDEPENDS:${PN} += " \ |
| 19 | libgpiod (>= 2.1) \ |
| 20 | python3-datetime \ |
| 21 | python3-profile \ |
| 22 | " |
| 23 | RDEPENDS:${PN}-ptest += " \ |
| 24 | libgpiod-ptest \ |
| 25 | python3-setuptools \ |
| 26 | " |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 27 | RRECOMMENDS:${PN}-ptest += "kernel-module-configfs" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 28 | |
| 29 | export LINK_SYSTEM_LIBGPIOD = "1" |
| 30 | |
| 31 | do_compile_ptest() { |
| 32 | setup_target_config |
| 33 | nativepython3 build_tests.py |
| 34 | } |
| 35 | |
| 36 | do_install_ptest() { |
| 37 | install -d ${D}${PTEST_PATH}/gpiod-test/gpiosim |
| 38 | install -d ${D}${PTEST_PATH}/gpiod-test/procname |
| 39 | install -m 0644 ${S}/tests/*.py ${D}${PTEST_PATH}/gpiod-test/ |
| 40 | install -m 0644 ${B}/tests/gpiosim/_ext* ${D}${PTEST_PATH}/gpiod-test/gpiosim |
| 41 | install -m 0644 ${S}/tests/gpiosim/*.py ${D}${PTEST_PATH}/gpiod-test/gpiosim |
| 42 | install -m 0644 ${B}/tests/procname/_ext* ${D}${PTEST_PATH}/gpiod-test/procname |
| 43 | install -m 0644 ${S}/tests/procname/*.py ${D}${PTEST_PATH}/gpiod-test/procname |
| 44 | } |
| 45 | |
| 46 | INSANE_SKIP:${PN}-ptest += "buildpaths" |