blob: d8c8628daac8645eac4f4f43eaa60858c8af42b5 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python bindings for libgpiod."
2
3LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & CC-BY-SA-4.0"
4# The actual license files live in the upstream libgpiod from which the pypi
5# package is spun out.
6LIC_FILES_CHKSUM = "file://setup.py;beginline=237;endline=237;md5=f5ddb56912b7f20bf94aa4d1bdcd3533"
7
8SRC_URI += "file://run-ptest"
9
10SRC_URI[sha256sum] = "a33193d6cab79d252329f71666a35a3668e04f1f82bf9b93ee2c9ae852398b20"
11
12inherit setuptools3-base python_pep517 ptest pypi
13
14DEPENDS += " \
15 libgpiod \
16 python3-setuptools-native \
17"
18RDEPENDS:${PN} += " \
19 libgpiod (>= 2.1) \
20 python3-datetime \
21 python3-profile \
22"
23RDEPENDS:${PN}-ptest += " \
24 libgpiod-ptest \
25 python3-setuptools \
26"
Patrick Williamsb58112e2024-03-07 11:16:36 -060027RRECOMMENDS:${PN}-ptest += "kernel-module-configfs"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028
29export LINK_SYSTEM_LIBGPIOD = "1"
30
31do_compile_ptest() {
32 setup_target_config
33 nativepython3 build_tests.py
34}
35
36do_install_ptest() {
37 install -d ${D}${PTEST_PATH}/gpiod-test/gpiosim
38 install -d ${D}${PTEST_PATH}/gpiod-test/procname
39 install -m 0644 ${S}/tests/*.py ${D}${PTEST_PATH}/gpiod-test/
40 install -m 0644 ${B}/tests/gpiosim/_ext* ${D}${PTEST_PATH}/gpiod-test/gpiosim
41 install -m 0644 ${S}/tests/gpiosim/*.py ${D}${PTEST_PATH}/gpiod-test/gpiosim
42 install -m 0644 ${B}/tests/procname/_ext* ${D}${PTEST_PATH}/gpiod-test/procname
43 install -m 0644 ${S}/tests/procname/*.py ${D}${PTEST_PATH}/gpiod-test/procname
44}
45
46INSANE_SKIP:${PN}-ptest += "buildpaths"