Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Protocol Buffers" |
| 2 | HOMEPAGE = "https://developers.google.com/protocol-buffers/" |
| 3 | SECTION = "devel/python" |
| 4 | |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=53dbfa56f61b90215a9f8f0d527c043d" |
| 7 | |
| 8 | inherit pypi setuptools3 |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "25b5d0b42fd000320bd7830b349e3b696435f3b329810427a6bcce6a5492cc5c" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 10 | |
| 11 | # http://errors.yoctoproject.org/Errors/Details/184715/ |
| 12 | # Can't find required file: ../src/google/protobuf/descriptor.proto |
| 13 | CLEANBROKEN = "1" |
| 14 | |
| 15 | UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/" |
| 16 | |
| 17 | DEPENDS += "protobuf" |
| 18 | |
| 19 | RDEPENDS:${PN} += " \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 20 | python3-datetime \ |
| 21 | python3-json \ |
| 22 | python3-logging \ |
| 23 | python3-netclient \ |
| 24 | python3-numbers \ |
| 25 | python3-pkgutil \ |
| 26 | python3-six \ |
| 27 | python3-unittest \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 28 | " |
| 29 | |
| 30 | # For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools) |
| 31 | BBCLASSEXTEND = "native nativesdk" |
| 32 | |
| 33 | DISTUTILS_BUILD_ARGS += "--cpp_implementation" |
| 34 | DISTUTILS_INSTALL_ARGS += "--cpp_implementation" |
| 35 | |
| 36 | do_compile:prepend:class-native () { |
| 37 | export KOKORO_BUILD_NUMBER="1" |
| 38 | } |