blob: 8bb8a93f76cf21c71562d2e4e72c0db4e5156b31 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Protocol Buffers"
2HOMEPAGE = "https://developers.google.com/protocol-buffers/"
3SECTION = "devel/python"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=53dbfa56f61b90215a9f8f0d527c043d"
7
8inherit pypi setuptools3
Patrick Williams39653562024-03-01 08:54:02 -06009SRC_URI[sha256sum] = "25b5d0b42fd000320bd7830b349e3b696435f3b329810427a6bcce6a5492cc5c"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060010
11# http://errors.yoctoproject.org/Errors/Details/184715/
12# Can't find required file: ../src/google/protobuf/descriptor.proto
13CLEANBROKEN = "1"
14
15UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
16
17DEPENDS += "protobuf"
18
19RDEPENDS:${PN} += " \
Patrick Williams39653562024-03-01 08:54:02 -060020 python3-datetime \
21 python3-json \
22 python3-logging \
23 python3-netclient \
24 python3-numbers \
25 python3-pkgutil \
26 python3-six \
27 python3-unittest \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028"
29
30# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
31BBCLASSEXTEND = "native nativesdk"
32
33DISTUTILS_BUILD_ARGS += "--cpp_implementation"
34DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
35
36do_compile:prepend:class-native () {
37 export KOKORO_BUILD_NUMBER="1"
38}