blob: 9cbe4927a27d1d5e990a2cc9cd539aa9ada75189 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001DESCRIPTION = "A utility belt for advanced users of python-requests."
2HOMEPAGE = "https://toolbelt.readthedocs.org"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05003
4LICENSE = "Apache-2.0"
Patrick Williams2194f502022-10-16 14:26:09 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=6f14302a4b4099009ab38b4dde5f1075"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05006
Andrew Geissler748a4832020-07-24 16:24:21 -05007SRC_URI = "file://run-ptest \
Andrew Geissler8f840682023-07-21 09:09:43 -05008 file://090856f4159c40a2927fb88546419f2e1697ad5f.patch \
9 file://720240501dca0b4eacc3295665d7ced8719e11d2.patch \
Andrew Geissler748a4832020-07-24 16:24:21 -050010 "
11
Andrew Geissler3eeda902023-05-19 10:14:02 -050012SRC_URI[sha256sum] = "7681a0a3d047012b5bdc0ee37d7f8f07ebe76ab08caeccfc3921ce23c88d5bc6"
Andrew Geisslerc87764f2020-06-27 00:16:32 -050013
Andrew Geissler748a4832020-07-24 16:24:21 -050014inherit pypi setuptools3 ptest
Andrew Geisslerc87764f2020-06-27 00:16:32 -050015
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060017 python3-requests (>=2.0.1) \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050018"
Andrew Geissler748a4832020-07-24 16:24:21 -050019
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060021 python3-betamax \
22 python3-mock \
23 python3-multiprocessing \
24 python3-pytest \
25 python3-trustme \
26 python3-unittest-automake-output \
Andrew Geissler748a4832020-07-24 16:24:21 -050027"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
32 cp -rf ${S}/setup.py ${D}${PTEST_PATH}
33 # remove test test_multipart_encoder.py as it fails,
34 # downloaded file is not supported
35 rm -f ${D}${PTEST_PATH}/tests/test_multipart_encoder.py
36}