Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Python module for Semantic Versioning" |
| 2 | HOMEPAGE = "https://github.com/python-semver/python-semver" |
| 3 | BUGTRACKER = "https://github.com/python-semver/python-semver" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d9da679db3bdce30a1b4328d5c474f98" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "6253adb39c70f6e51afed2fa7152bcd414c411286088fb4b9effb133885ab4cc" |
| 8 | |
| 9 | inherit pypi python_setuptools_build_meta ptest |
| 10 | |
| 11 | BBCLASSEXTEND = "native nativesdk" |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | DEPENDS += " python3-setuptools-scm-native" |
| 18 | |
| 19 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 20 | python3-pytest \ |
| 21 | python3-unittest-automake-output \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ |
| 26 | } |