Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Fast, pure-Python full text indexing, search, and spell checking library." |
| 2 | DESCRIPTION = "\ |
| 3 | Whoosh is a fast, featureful full-text indexing and searching library \ |
| 4 | implemented in pure Python. Programmers can use it to easily add search \ |
| 5 | functionality to their applications and websites. Every part of how \ |
| 6 | Whoosh works can be extended or replaced to meet your needs exactly." |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05303186defc6141143629961c7c8a60" |
| 9 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame^] | 10 | SRC_URI += "file://0001-Mark-non-determinstic-test_minimize_dfa-test-as-XFAI.patch" |
| 11 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | SRC_URI[md5sum] = "893433e9c0525ac043df33e6e04caab2" |
| 13 | SRC_URI[sha256sum] = "e0857375f63e9041e03fedd5b7541f97cf78917ac1b6b06c1fcc9b45375dda69" |
| 14 | |
| 15 | PYPI_PACKAGE = "Whoosh" |
| 16 | PYPI_PACKAGE_EXT = "zip" |
| 17 | |
| 18 | inherit ptest pypi setuptools3 |
| 19 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | RDEPENDS:${PN} += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 21 | python3-email \ |
| 22 | python3-multiprocessing \ |
| 23 | python3-netclient \ |
| 24 | python3-numbers \ |
| 25 | python3-pickle \ |
| 26 | python3-shell \ |
| 27 | python3-stringold \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 28 | " |
| 29 | |
| 30 | SRC_URI += " \ |
| 31 | file://run-ptest \ |
| 32 | " |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 35 | python3-fcntl \ |
| 36 | python3-pytest \ |
| 37 | python3-unittest-automake-output \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 38 | " |
| 39 | |
| 40 | do_install_ptest() { |
| 41 | install -d ${D}${PTEST_PATH}/tests |
| 42 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 43 | } |