blob: 406de2e525cd971f799e98db2a4e707edc2c1b4d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Fast, pure-Python full text indexing, search, and spell checking library."
2DESCRIPTION = "\
3Whoosh is a fast, featureful full-text indexing and searching library \
4implemented in pure Python. Programmers can use it to easily add search \
5functionality to their applications and websites. Every part of how \
6Whoosh works can be extended or replaced to meet your needs exactly."
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05303186defc6141143629961c7c8a60"
9
Patrick Williams44b3caf2024-04-12 16:51:14 -050010SRC_URI += "file://0001-Mark-non-determinstic-test_minimize_dfa-test-as-XFAI.patch"
11
Andrew Geissler82c905d2020-04-13 13:39:40 -050012SRC_URI[md5sum] = "893433e9c0525ac043df33e6e04caab2"
13SRC_URI[sha256sum] = "e0857375f63e9041e03fedd5b7541f97cf78917ac1b6b06c1fcc9b45375dda69"
14
15PYPI_PACKAGE = "Whoosh"
16PYPI_PACKAGE_EXT = "zip"
17
18inherit ptest pypi setuptools3
19
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060021 python3-email \
22 python3-multiprocessing \
23 python3-netclient \
24 python3-numbers \
25 python3-pickle \
26 python3-shell \
27 python3-stringold \
Andrew Geissler82c905d2020-04-13 13:39:40 -050028"
29
30SRC_URI += " \
31 file://run-ptest \
32"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060035 python3-fcntl \
36 python3-pytest \
37 python3-unittest-automake-output \
Andrew Geissler82c905d2020-04-13 13:39:40 -050038"
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/tests
42 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
43}