blob: 29897b7f1ca0ccbb451b35d404f83ec4a10167eb [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
Andrew Geissler3eeda902023-05-19 10:14:02 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
Andrew Geissler517393d2023-01-13 08:55:19 -06005
Patrick Williams169d7bc2024-01-05 11:33:25 -06006SRC_URI[sha256sum] = "566db86717cf8080b99b58b083b773a908ae40f06681e87e589a976faf8246bf"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8SRC_URI += "file://run-ptest"
9
10PYPI_PACKAGE = "yarl"
11
Patrick Williams169d7bc2024-01-05 11:33:25 -060012inherit pypi ptest python_setuptools_build_meta
13
14DEPENDS += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060015 python3-expandvars-native \
16 python3-cython-native \
Patrick Williams169d7bc2024-01-05 11:33:25 -060017"
Andrew Geissler517393d2023-01-13 08:55:19 -060018
19RDEPENDS:${PN} = "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060020 python3-multidict \
21 python3-idna \
22 python3-io \
Andrew Geissler517393d2023-01-13 08:55:19 -060023"
24
25RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060026 python3-pytest \
27 python3-unittest-automake-output \
Andrew Geissler517393d2023-01-13 08:55:19 -060028"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
33}