blob: 848f74d612a114c7dc18616127e6f0f211e1414a [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Powerful Python library for atomic file writes"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06002HOMEPAGE = "https://github.com/untitaker/python-atomicwrites"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=91cc36cfafeefb7863673bcfcb1d4da4"
5
Andrew Geissler615f2f12022-07-15 14:00:58 -05006SRC_URI[sha256sum] = "81b2c9071a49367a7f770170e5eec8cb66567cfbbc8c73d20ce5ca4a8d71cf11"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060015 python3-pytest \
16 python3-unittest-automake-output \
17 python3-unixadmin \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060018"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
Patrick Williams73bd93f2024-02-20 08:07:48 -060025RDEPENDS:${PN} = "python3-misc"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060026
27BBCLASSEXTEND = "native nativesdk"