Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "An implementation of JSON Schema validation for Python" |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/python-jsonschema/jsonschema" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \ |
| 5 | file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af" |
| 6 | |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "85727c00279f5fa6bedbe6238d2aa6403bedd8b4864ab11207d07df3cc1b2ee5" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 8 | |
| 9 | inherit pypi python_hatchling |
| 10 | |
| 11 | PACKAGES =+ "${PN}-tests" |
| 12 | FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/jsonschema/tests" |
| 13 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 14 | DEPENDS += "python3-hatch-fancy-pypi-readme-native python3-hatch-vcs-native " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | PACKAGECONFIG ??= "format" |
| 17 | PACKAGECONFIG[format] = ",,,\ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 18 | python3-idna \ |
| 19 | python3-jsonpointer \ |
| 20 | python3-webcolors \ |
| 21 | python3-rfc3987 \ |
| 22 | python3-rfc3339-validator \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 23 | " |
| 24 | PACKAGECONFIG[nongpl] = ",,,\ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 25 | python3-idna \ |
| 26 | python3-jsonpointer \ |
| 27 | python3-webcolors \ |
| 28 | python3-rfc3986-validator \ |
| 29 | python3-rfc3339-validator \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 30 | " |
| 31 | |
| 32 | RDEPENDS:${PN} += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 33 | python3-attrs \ |
| 34 | python3-core \ |
| 35 | python3-datetime \ |
| 36 | python3-importlib-metadata \ |
| 37 | python3-io \ |
| 38 | python3-json \ |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 39 | python3-jsonschema-specifications \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 40 | python3-netclient \ |
| 41 | python3-numbers \ |
| 42 | python3-pprint \ |
| 43 | python3-pyrsistent \ |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 44 | python3-referencing \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 45 | python3-zipp \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 46 | " |
| 47 | |
| 48 | RDEPENDS:${PN}-tests = "${PN}" |
| 49 | |
| 50 | BBCLASSEXTEND = "native nativesdk" |