blob: 381148f4bb76c4fc57cd5e3cc7984a465b1f58c8 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "An implementation of JSON Schema validation for Python"
Andrew Geissler220dafd2023-10-04 10:18:08 -05002HOMEPAGE = "https://github.com/python-jsonschema/jsonschema"
Andrew Geissler517393d2023-01-13 08:55:19 -06003LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
5 file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af"
6
Patrick Williamsb58112e2024-03-07 11:16:36 -06007SRC_URI[sha256sum] = "85727c00279f5fa6bedbe6238d2aa6403bedd8b4864ab11207d07df3cc1b2ee5"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9inherit pypi python_hatchling
10
11PACKAGES =+ "${PN}-tests"
12FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/jsonschema/tests"
13
Patrick Williams73bd93f2024-02-20 08:07:48 -060014DEPENDS += "python3-hatch-fancy-pypi-readme-native python3-hatch-vcs-native "
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16PACKAGECONFIG ??= "format"
17PACKAGECONFIG[format] = ",,,\
Patrick Williams73bd93f2024-02-20 08:07:48 -060018 python3-idna \
19 python3-jsonpointer \
20 python3-webcolors \
21 python3-rfc3987 \
22 python3-rfc3339-validator \
Andrew Geissler517393d2023-01-13 08:55:19 -060023"
24PACKAGECONFIG[nongpl] = ",,,\
Patrick Williams73bd93f2024-02-20 08:07:48 -060025 python3-idna \
26 python3-jsonpointer \
27 python3-webcolors \
28 python3-rfc3986-validator \
29 python3-rfc3339-validator \
Andrew Geissler517393d2023-01-13 08:55:19 -060030"
31
32RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060033 python3-attrs \
34 python3-core \
35 python3-datetime \
36 python3-importlib-metadata \
37 python3-io \
38 python3-json \
Patrick Williamsb58112e2024-03-07 11:16:36 -060039 python3-jsonschema-specifications \
Patrick Williams73bd93f2024-02-20 08:07:48 -060040 python3-netclient \
41 python3-numbers \
42 python3-pprint \
43 python3-pyrsistent \
Patrick Williamsb58112e2024-03-07 11:16:36 -060044 python3-referencing \
Patrick Williams73bd93f2024-02-20 08:07:48 -060045 python3-zipp \
Andrew Geissler517393d2023-01-13 08:55:19 -060046"
47
48RDEPENDS:${PN}-tests = "${PN}"
49
50BBCLASSEXTEND = "native nativesdk"