Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 1 | SUMMARY = "Simple powerful testing with python" |
| 2 | HOMEPAGE = "https://pypi.org/project/pytest/" |
| 3 | DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries." |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bd27e41b6550fe0fc45356d1d81ee37c" |
| 7 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame^] | 8 | SRC_URI[sha256sum] = "ac978141a75948948817d360297b7aae0fcb9d6ff6bc9ec6d514b85d5a65c044" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 9 | |
| 10 | DEPENDS += "python3-setuptools-scm-native" |
| 11 | |
| 12 | inherit update-alternatives pypi python_setuptools_build_meta |
| 13 | |
| 14 | RDEPENDS:${PN} += " \ |
| 15 | python3-atomicwrites \ |
| 16 | python3-attrs \ |
| 17 | python3-debugger \ |
| 18 | python3-doctest \ |
| 19 | python3-importlib-metadata \ |
| 20 | python3-iniconfig \ |
| 21 | python3-json \ |
| 22 | python3-more-itertools \ |
| 23 | python3-packaging \ |
| 24 | python3-pathlib2 \ |
| 25 | python3-pluggy \ |
| 26 | python3-py \ |
| 27 | python3-setuptools \ |
| 28 | python3-six \ |
| 29 | python3-tomllib \ |
| 30 | python3-wcwidth \ |
| 31 | " |
| 32 | |
| 33 | ALTERNATIVE:${PN} += "py.test pytest" |
| 34 | |
| 35 | NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" |
| 36 | ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" |
| 37 | |
| 38 | ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" |
| 39 | ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" |
| 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |