Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Python support for YAML" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 2 | DEPENDS += "libyaml python3-cython-native" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 3 | HOMEPAGE = "https://pyyaml.org/" |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6d8242660a8371add5fe547adf083079" |
| 7 | |
| 8 | PYPI_PACKAGE = "PyYAML" |
| 9 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | inherit pypi python_setuptools_build_meta |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 11 | |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 12 | SRC_URI += "file://0001-Fix-builds-with-Cython-3.patch" |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "bfdf460b1736c775f2ba9f6a92bca30bc2095067b8a9d77876d1fad6cc3b4a43" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 14 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 15 | PACKAGECONFIG ?= "libyaml" |
| 16 | PACKAGECONFIG[libyaml] = "--with-libyaml,--without-libyaml,libyaml" |
| 17 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 18 | RDEPENDS:${PN} += "\ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 19 | python3-datetime \ |
| 20 | python3-netclient \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 21 | " |
| 22 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 23 | inherit ptest |
| 24 | SRC_URI += "\ |
| 25 | https://raw.githubusercontent.com/yaml/pyyaml/a98fd6088e81d7aca571220c966bbfe2ac43c335/tests/test_dump_load.py;name=test \ |
| 26 | file://run-ptest \ |
| 27 | " |
| 28 | SRC_URI[test.sha256sum] = "b6a8a2825d89fdc8aee226560f66b8196e872012a0ea7118cbef1a832359434a" |
| 29 | |
| 30 | RDEPENDS:${PN}-ptest += " \ |
| 31 | python3-pytest \ |
| 32 | python3-unittest-automake-output \ |
| 33 | " |
| 34 | |
| 35 | do_install_ptest() { |
| 36 | install -d ${D}${PTEST_PATH}/tests |
| 37 | cp -rf ${WORKDIR}/test_dump_load.py ${D}${PTEST_PATH}/tests/ |
| 38 | } |
| 39 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 40 | BBCLASSEXTEND = "native nativesdk" |