blob: 3388312557038f96605cfd3740fe9f97e7d40046 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python support for YAML"
Patrick Williams73bd93f2024-02-20 08:07:48 -06002DEPENDS += "libyaml python3-cython-native"
Andrew Geisslereff27472021-10-29 15:35:00 -05003HOMEPAGE = "https://pyyaml.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=6d8242660a8371add5fe547adf083079"
7
8PYPI_PACKAGE = "PyYAML"
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010inherit pypi python_setuptools_build_meta
Andrew Geisslereff27472021-10-29 15:35:00 -050011
Patrick Williams705982a2024-01-12 09:51:57 -060012SRC_URI += "file://0001-Fix-builds-with-Cython-3.patch"
Patrick Williams2a254922023-08-11 09:48:11 -050013SRC_URI[sha256sum] = "bfdf460b1736c775f2ba9f6a92bca30bc2095067b8a9d77876d1fad6cc3b4a43"
Andrew Geisslereff27472021-10-29 15:35:00 -050014
Patrick Williams73bd93f2024-02-20 08:07:48 -060015PACKAGECONFIG ?= "libyaml"
16PACKAGECONFIG[libyaml] = "--with-libyaml,--without-libyaml,libyaml"
17
Andrew Geisslereff27472021-10-29 15:35:00 -050018RDEPENDS:${PN} += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-datetime \
20 python3-netclient \
Andrew Geisslereff27472021-10-29 15:35:00 -050021"
22
Patrick Williams73bd93f2024-02-20 08:07:48 -060023inherit ptest
24SRC_URI += "\
25 https://raw.githubusercontent.com/yaml/pyyaml/a98fd6088e81d7aca571220c966bbfe2ac43c335/tests/test_dump_load.py;name=test \
26 file://run-ptest \
27"
28SRC_URI[test.sha256sum] = "b6a8a2825d89fdc8aee226560f66b8196e872012a0ea7118cbef1a832359434a"
29
30RDEPENDS:${PN}-ptest += " \
31 python3-pytest \
32 python3-unittest-automake-output \
33"
34
35do_install_ptest() {
36 install -d ${D}${PTEST_PATH}/tests
37 cp -rf ${WORKDIR}/test_dump_load.py ${D}${PTEST_PATH}/tests/
38}
39
Andrew Geisslereff27472021-10-29 15:35:00 -050040BBCLASSEXTEND = "native nativesdk"