blob: 4a9bf7532336aa1578587952707b88d895e8c511 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Library for building powerful interactive command lines in Python"
2DESCRIPTION = "Measures the displayed width of unicode strings in a terminal"
3HOMEPAGE = "https://github.com/jquast/wcwidth"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb"
6
Patrick Williamsb58112e2024-03-07 11:16:36 -06007SRC_URI[sha256sum] = "72ea0c06399eb286d978fdedb6923a9eb47e1c486ce63e9b4e64fc18303972b5"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060016 python3-pytest \
17 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060018"
19
20do_install_ptest() {
Patrick Williamsb58112e2024-03-07 11:16:36 -060021 install -d ${D}${PTEST_PATH}/tests
Patrick Williamsac13d5f2023-11-24 18:59:46 -060022 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
Patrick Williamsb58112e2024-03-07 11:16:36 -060023 install -d ${D}${PTEST_PATH}/bin
24 cp -rf ${S}/bin/* ${D}${PTEST_PATH}/bin/
Patrick Williamsac13d5f2023-11-24 18:59:46 -060025}
26
27BBCLASSEXTEND = "native nativesdk"