Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Library for building powerful interactive command lines in Python" |
| 2 | DESCRIPTION = "Measures the displayed width of unicode strings in a terminal" |
| 3 | HOMEPAGE = "https://github.com/jquast/wcwidth" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb" |
| 6 | |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "72ea0c06399eb286d978fdedb6923a9eb47e1c486ce63e9b4e64fc18303972b5" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 8 | |
| 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
| 15 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 16 | python3-pytest \ |
| 17 | python3-unittest-automake-output \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | do_install_ptest() { |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 21 | install -d ${D}${PTEST_PATH}/tests |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 22 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 23 | install -d ${D}${PTEST_PATH}/bin |
| 24 | cp -rf ${S}/bin/* ${D}${PTEST_PATH}/bin/ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 25 | } |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |