Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | # TODO: include debian's mtp-tools man page (needs xsltproc-native and |
| 2 | # docbook-xsl-native, or we pregenerate it), add support for doxygen |
| 3 | # generation fully with -natives |
| 4 | DESCRIPTION = "libmtp is an Initiator implementation of the Media Transfer \ |
| 5 | Protocol (MTP) in the form of a library suitable primarily for POSIX \ |
| 6 | compliant operating systems" |
| 7 | SUMMARY = "libmtp is an Initiator implementation of the Media Transfer Protocol (MTP)" |
| 8 | HOMEPAGE = "http://libmtp.sourceforge.net/" |
| 9 | LICENSE = "LGPL-2.1-or-later" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=0448d3676bc0de00406af227d341a4d1 \ |
| 11 | file://src/ptp.c;beginline=3;endline=22;md5=80fd2d5904c4c1f5455d8f4bf515292f \ |
| 12 | file://examples/albums.c;beginline=5;endline=21;md5=84f4e55dfec49e898b7f68a828c15620 \ |
| 13 | " |
| 14 | |
| 15 | BBCLASSEXTEND = "native" |
| 16 | |
| 17 | DEPENDS = "libusb1 gettext-native" |
| 18 | DEPENDS:append:class-target = " ${BPN}-native" |
| 19 | |
| 20 | SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz" |
| 21 | SRC_URI:append:class-target = " file://0001-Use-native-mtp-hotplug.patch" |
| 22 | SRC_URI[sha256sum] = "f4c1ceb3df020a6cb851110f620c14fe399518c494ed252039cbfb4e34335135" |
| 23 | |
| 24 | inherit autotools pkgconfig lib_package |
| 25 | |
| 26 | EXTRA_OECONF += " \ |
| 27 | --disable-rpath \ |
| 28 | --enable-largefile \ |
| 29 | --with-udev=${nonarch_base_libdir}/udev \ |
| 30 | " |
| 31 | |
| 32 | PACKAGECONFIG ?= "" |
| 33 | PACKAGECONFIG[doxygen] = "--enable-doxygen,--disable-doxygen,doxygen-native" |
| 34 | PACKAGECONFIG[mtpz] = "--enable-mtpz,--disable-mtpz,libgcrypt" |
| 35 | |
| 36 | PACKAGES =+ "${BPN}-common ${BPN}-runtime" |
| 37 | |
| 38 | RDEPENDS:${BPN} += "libmtp-common" |
| 39 | RRECOMMENDS:${BPN} += "libmtp-runtime ${PN}-bin" |
| 40 | |
| 41 | FILES:${BPN}-common = "${nonarch_base_libdir}/udev/rules.d/*" |
| 42 | SUMMARY:${BPN}-common = "The udev rules file for MTP devices" |
| 43 | |
| 44 | FILES:${BPN}-runtime = "${nonarch_base_libdir}/udev/mtp-probe" |
| 45 | RDEPENDS:${BPN}-runtime = "libmtp-common" |
| 46 | SUMMARY:${BPN}-runtime = "mtp-probe, used for the MTP udev rules" |
| 47 | DESCRIPTION:${BPN}-runtime = "This package provides mtp-probe, a program to probe newly connected device interfaces from userspace to determine if they are MTP devices, used for udev rules." |