Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Paho MQTT - C++ libraries for the MQTT and MQTT-SN protocols" |
| 2 | DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)." |
| 3 | HOMEPAGE = "http://www.eclipse.org/paho/" |
| 4 | SECTION = "console/network" |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 5 | LICENSE = "EPL-2.0 | EDL-1.0" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 6 | |
| 7 | LIC_FILES_CHKSUM = " \ |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 8 | file://src/mqtt/message.h;beginline=9;endline=18;md5=c5ceecf5ab99d44dcfaaabdce289071b \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \ |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 10 | file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | " |
| 12 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 13 | SRC_URI = "git://github.com/eclipse/paho.mqtt.cpp;protocol=https;branch=v1.3.x \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | file://0001-cmake-Use-CMAKE_INSTALL_LIBDIR-and-CMAKE_INSTALL_BIN.patch \ |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 15 | " |
| 16 | SRCREV = "5e0d1bf37b4826d680ec066ec42afd133851a681" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | |
| 18 | DEPENDS = "openssl paho-mqtt-c" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit cmake |
| 23 | |
| 24 | EXTRA_OECMAKE += "-DPAHO_WITH_SSL=ON" |