blob: f88d3b6ca19970a1edf448a5134b6b0b55cc87c2 [file] [log] [blame]
Andrew Geisslerd5838332022-05-27 11:33:10 -05001SUMMARY = "cpulimit is a tool which limits the CPU usage of a process"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06002DESCRIPTION = "cpulimit is a simple program that attempts to limit the CPU usage of a process (expressed in percentage, not in CPU time). This is useful to control batch jobs, when you don't want them to eat too much CPU. It does not act on the nice value or other priority stuff, but on the real CPU usage. Besides it is able to adapt itself to the overall system load, dynamically and quickly."
Andrew Geisslerd5838332022-05-27 11:33:10 -05003HOMEPAGE = "http://cpulimit.sourceforge.net"
4LICENSE = "GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86c1c0d961a437e529db93aa3bb32dc4"
6SRCREV ?= "f4d2682804931e7aea02a869137344bb5452a3cd"
7
Andrew Geissler3eeda902023-05-19 10:14:02 -05008SRC_URI = "git://github.com/opsengine/cpulimit.git;protocol=https;branch=master \
Andrew Geisslerd5838332022-05-27 11:33:10 -05009 file://0001-Remove-sys-sysctl.h-and-add-missing-libgen.h-include.patch \
10 "
11
12S = "${WORKDIR}/git"
13
14do_compile() {
15 oe_runmake all
16}
17do_install() {
18 install -d ${D}${sbindir}
Andrew Geissler3eeda902023-05-19 10:14:02 -050019 install -m 0755 ${B}/src/${BPN} ${D}${sbindir}/
Andrew Geisslerd5838332022-05-27 11:33:10 -050020}
21
Patrick Williams92b42cb2022-09-03 06:53:57 -050022CFLAGS += "-D_GNU_SOURCE ${LDFLAGS}"
Andrew Geisslerd5838332022-05-27 11:33:10 -050023