blob: 96833b8859d2b5e58cee4e7acf0c1957116deb27 [file] [log] [blame]
William A. Kennington IIIc4721762021-02-08 17:50:01 -08001SUMMARY = "Google NCSI daemon"
2DESCRIPTION = "Google NCSI daemon."
3HOMEPAGE = "http://github.com/openbmc/google-misc"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://../LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
9
10SRC_URI += "git://github.com/openbmc/google-misc"
Andrew Geissler7354cf72021-02-09 04:20:12 +000011SRCREV = "a65b7b8174de2720b3abe97ebc95a4619bc1bd73"
William A. Kennington IIIc4721762021-02-08 17:50:01 -080012S = "${WORKDIR}/git/ncsid"
13
14inherit meson systemd
15
16SYSTEMD_SERVICE_${PN} += " \
17 dhcp4@.service \
18 dhcp6@.service \
19 ncsid@.service \
20 nic-hostful@.target \
21 nic-hostless@.target \
22 update-static-neighbors@.service \
23 update-static-neighbors@.timer \
24"
25
26DEPENDS += " \
27 fmt \
28 sdbusplus \
29 stdplus \
30"
31
32RDEPENDS_${PN} += " \
33 bash \
34 busybox \
35 iputils-arping \
36 jq \
37 ndisc6-ndisc6 \
38 ndisc6-rdisc6 \
39 systemd \
40"