William A. Kennington III | c472176 | 2021-02-08 17:50:01 -0800 | [diff] [blame] | 1 | SUMMARY = "Google NCSI daemon" |
| 2 | DESCRIPTION = "Google NCSI daemon." |
| 3 | HOMEPAGE = "http://github.com/openbmc/google-misc" |
| 4 | PR = "r1" |
| 5 | PV = "1.0+git${SRCPV}" |
| 6 | |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=34400b68072d710fecd0a2940a0d1658" |
| 9 | |
| 10 | SRC_URI += "git://github.com/openbmc/google-misc" |
Andrew Geissler | 7354cf7 | 2021-02-09 04:20:12 +0000 | [diff] [blame] | 11 | SRCREV = "a65b7b8174de2720b3abe97ebc95a4619bc1bd73" |
William A. Kennington III | c472176 | 2021-02-08 17:50:01 -0800 | [diff] [blame] | 12 | S = "${WORKDIR}/git/ncsid" |
| 13 | |
| 14 | inherit meson systemd |
| 15 | |
| 16 | SYSTEMD_SERVICE_${PN} += " \ |
| 17 | dhcp4@.service \ |
| 18 | dhcp6@.service \ |
| 19 | ncsid@.service \ |
| 20 | nic-hostful@.target \ |
| 21 | nic-hostless@.target \ |
| 22 | update-static-neighbors@.service \ |
| 23 | update-static-neighbors@.timer \ |
| 24 | " |
| 25 | |
| 26 | DEPENDS += " \ |
| 27 | fmt \ |
| 28 | sdbusplus \ |
| 29 | stdplus \ |
| 30 | " |
| 31 | |
| 32 | RDEPENDS_${PN} += " \ |
| 33 | bash \ |
| 34 | busybox \ |
| 35 | iputils-arping \ |
| 36 | jq \ |
| 37 | ndisc6-ndisc6 \ |
| 38 | ndisc6-rdisc6 \ |
| 39 | systemd \ |
| 40 | " |