Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "library with support for Expert Witness Compression Format" |
| 2 | LICENSE = "LGPLv3+" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=58c39b26c0549f8e1bb4122173f474cd" |
| 4 | |
| 5 | DEPENDS = "virtual/gettext libtool" |
| 6 | |
| 7 | SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/universe/libe/${BPN}/${BPN}_${PV}.orig.tar.gz;name=orig \ |
| 8 | file://gcc5_fix.patch \ |
| 9 | " |
| 10 | SRC_URI[orig.md5sum] = "fdf615f23937fad8e02b60b9e3e5fb35" |
| 11 | SRC_URI[orig.sha256sum] = "d14030ce6122727935fbd676d0876808da1e112721f3cb108564a4d9bf73da71" |
| 12 | |
| 13 | inherit autotools-brokensep pkgconfig gettext |
| 14 | |
| 15 | PACKAGECONFIG ??= "zlib ssl bz2" |
| 16 | PACKAGECONFIG[zlib] = "--with-zlib, --without-zlib, zlib, zlib" |
| 17 | PACKAGECONFIG[bz2] = "--with-bzip2, --without-bzip2, bzip2, bzip2" |
| 18 | PACKAGECONFIG[ssl] = "--with-openssl, --without-openssl, openssl, openssl" |
| 19 | PACKAGECONFIG[fuse] = "--with-libfuse, --without-libfuse, fuse" |
| 20 | PACKAGECONFIG[python] = "--enable-python, --disable-python, python" |
| 21 | |
| 22 | EXTRA_OECONF += "--with-gnu-ld --disable-rpath" |
| 23 | |
| 24 | RDEPENDS_${PN} += " util-linux-libuuid" |