Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "LevelDB is a fast key-value storage library" |
| 2 | DESCRIPTION = "LevelDB is a fast key-value storage library that provides an ordered mapping from string keys to string values" |
| 3 | HOMEPAGE = "https://github.com/google/leveldb" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=92d1b128950b11ba8495b64938fc164d" |
| 6 | |
| 7 | SRC_URI = "gitsm://github.com/google/${BPN}.git;branch=main;protocol=https \ |
| 8 | file://0001-CMakeLists.txt-fix-googletest-related-options.patch \ |
| 9 | file://0001-Fix-printing-64-bit-integer-types.patch \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | |
| 13 | SRCREV = "068d5ee1a3ac40dabd00d211d5013af44be55bea" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake ptest |
| 17 | PACKAGECONFIG ??= "" |
| 18 | PACKAGECONFIG[benchmarks] = "-DLEVELDB_BUILD_BENCHMARKS=ON,-DLEVELDB_BUILD_BENCHMARKS=OFF,sqlite" |
| 19 | PACKAGECONFIG[snappy] = ",,snappy" |
| 20 | PACKAGECONFIG[tcmalloc] = ",,gperftools" |
| 21 | |
| 22 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=RelWithDebInfo -DBUILD_SHARED_LIBS=ON -DCMAKE_SKIP_RPATH=ON \ |
| 23 | -DLEVELDB_BUILD_TESTS=${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'ON', 'OFF', d)}" |
| 24 | |
| 25 | do_install:append() { |
| 26 | install -D -m 0755 ${B}/leveldbutil ${D}${bindir}/leveldbutil |
| 27 | } |
| 28 | |
| 29 | do_install_ptest() { |
| 30 | install -m 0755 ${B}/*_test ${D}${PTEST_PATH} |
| 31 | } |
| 32 | |
| 33 | # Do not try to build lib32-leveldb for mips64, but allow libn32-leveldb. |
| 34 | # |
| 35 | COMPATIBLE_HOST:mipsarcho32:pn-lib32-leveldb = "null" |