Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Desktop containment framework." |
| 2 | HOMEPAGE = "http://flatpak.org" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 5 | |
| 6 | SRC_URI = " \ |
| 7 | gitsm://github.com/flatpak/flatpak;protocol=https;branch=main \ |
| 8 | file://0001-flatpak-pc-add-pc_sysrootdir.patch \ |
| 9 | file://0001-meson.build-require-for-native-wayland-scanner.patch \ |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 10 | file://0001-meson.build-require-native-gtkdoc.patch \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 11 | " |
| 12 | |
| 13 | SRCREV = "27b11b93c2a80a91c9461bc6c7f5e9a201406041" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit meson pkgconfig gettext systemd gtk-doc gobject-introspection python3native useradd mime features_check |
| 18 | |
| 19 | REQUIRED_DISTRO_FEATURES = "polkit" |
| 20 | |
| 21 | DEPENDS = " \ |
| 22 | appstream \ |
| 23 | bison-native \ |
| 24 | dconf \ |
| 25 | fuse3 \ |
| 26 | gdk-pixbuf \ |
| 27 | glib-2.0 \ |
| 28 | gpgme \ |
| 29 | json-glib \ |
| 30 | libarchive \ |
| 31 | libcap \ |
| 32 | libxml2 \ |
| 33 | ostree \ |
| 34 | polkit \ |
| 35 | python3-pyparsing-native \ |
| 36 | zstd \ |
| 37 | " |
| 38 | |
| 39 | RDEPENDS:${PN} = " \ |
| 40 | bubblewrap \ |
| 41 | ca-certificates \ |
| 42 | dconf \ |
| 43 | flatpak-xdg-utils \ |
| 44 | xdg-dbus-proxy \ |
| 45 | " |
| 46 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 47 | GIR_MESON_OPTION = "gir" |
| 48 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 49 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 50 | GTKDOC_MESON_OPTION = 'gtkdoc' |
| 51 | GTKDOC_MESON_ENABLE_FLAG = 'enabled' |
| 52 | GTKDOC_MESON_DISABLE_FLAG = 'disabled' |
| 53 | |
| 54 | PACKAGECONFIG[curl] = "-Dhttp_backend=curl,,curl" |
| 55 | PACKAGECONFIG[docbook_docs] = "-Ddocbook_docs=enabled,-Ddocbook_docs=disabled,xmlto-native" |
| 56 | PACKAGECONFIG[man] = "-Dman=enabled,-Dman=disabled,libxslt-native" |
| 57 | PACKAGECONFIG[soup] = "-Dhttp_backend=soup,,libsoup-2.4" |
| 58 | PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,xauth socat-native" |
| 59 | PACKAGECONFIG[xauth] = "-Dxauth=enabled,-Dxauth=disabled,xauth" |
| 60 | PACKAGECONFIG[seccomp] = "-Dseccomp=enabled,-Dseccomp=disabled,libseccomp" |
| 61 | PACKAGECONFIG[selinux] = "-Dselinux_module=enabled,-Dselinux_module=disabled,libselinux" |
| 62 | PACKAGECONFIG[wayland-security-context] = "-Dwayland_security_context=enabled,-Dwayland_security_context=disabled,wayland wayland-native wayland-protocols" |
| 63 | |
| 64 | PACKAGECONFIG ?= " \ |
| 65 | curl \ |
| 66 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xauth', '', d)} \ |
| 67 | ${@bb.utils.contains('DISTRO_FEATURES', 'seccomp', 'seccomp', '', d)} \ |
| 68 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-security-context', '', d)} \ |
| 69 | " |
| 70 | |
| 71 | FILES:${PN} += "${libdir} ${datadir}" |
| 72 | |
| 73 | USERADD_PACKAGES = "${PN}" |
| 74 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd" |
| 75 | |
| 76 | do_install:append() { |
| 77 | chmod 0700 ${D}/${datadir}/polkit-1/rules.d |
| 78 | chown polkitd ${D}/${datadir}/polkit-1/rules.d |
| 79 | chgrp root ${D}/${datadir}/polkit-1/rules.d |
| 80 | } |