blob: 8e38517448aa1a03be47a90ee59514f00206b371 [file] [log] [blame]
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05001SUMMARY = "C-Periphery lib used to access GPIO, LED, PWM, SPI, I2C, MMIO, Serial"
Andrew Geissler89770b02020-06-13 10:40:47 -05002DESCRIPTION = "A C library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux"
3
4HOMEPAGE = "https://github.com/vsergeev/c-periphery"
5
6SECTION = "libs"
7
8LICENSE = "MIT"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05009LIC_FILES_CHKSUM = "file://LICENSE;md5=be30d45bdc453f70a494c149c2168289"
Andrew Geissler89770b02020-06-13 10:40:47 -050010
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://github.com/vsergeev/c-periphery;protocol=https;branch=master"
Patrick Williams2a254922023-08-11 09:48:11 -050012SRCREV = "91f9678d2a35a3af3c633f20165bdde8bea32209"
Andrew Geissler89770b02020-06-13 10:40:47 -050013
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
19
20BBCLASSEXTEND = "native nativesdk"
21