blob: 970844f982452f19c0c7cf367a103f3811f0f52d [file] [log] [blame]
Patrick Williams169d7bc2024-01-05 11:33:25 -06001SUMMARY = "driverctl is a device driver control utility for Linux"
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
4
5REQUIRED_DISTRO_FEATURES = "systemd"
6
7DEPENDS = "systemd"
8RDEPENDS:${PN} += "bash bash-completion"
9
10SRC_URI = "git://gitlab.com/driverctl/driverctl.git;branch=master;protocol=https"
11SRCREV = "2ba60536eb20ca0a6a751bd8b6501dba84ec45d3"
12
13S = "${WORKDIR}/git"
14
15inherit pkgconfig systemd features_check
16
17do_install () {
18 oe_runmake install DESTDIR=${D}
19}
20
21FILES:${PN} += " \
22 ${libdir} \
23 ${datadir} \
24 ${systemd_system_unitdir} \
25"
26