Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | SUMMARY = "driverctl is a device driver control utility for Linux" |
| 2 | LICENSE = "LGPL-2.1-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 4 | |
| 5 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 6 | |
| 7 | DEPENDS = "systemd" |
| 8 | RDEPENDS:${PN} += "bash bash-completion" |
| 9 | |
| 10 | SRC_URI = "git://gitlab.com/driverctl/driverctl.git;branch=master;protocol=https" |
| 11 | SRCREV = "2ba60536eb20ca0a6a751bd8b6501dba84ec45d3" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit pkgconfig systemd features_check |
| 16 | |
| 17 | do_install () { |
| 18 | oe_runmake install DESTDIR=${D} |
| 19 | } |
| 20 | |
| 21 | FILES:${PN} += " \ |
| 22 | ${libdir} \ |
| 23 | ${datadir} \ |
| 24 | ${systemd_system_unitdir} \ |
| 25 | " |
| 26 | |