blob: 2fe61e6f5969630a9d2305e10b9a293e4b7589c6 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Receive a forwarded serial from serial-forward and provide a PTY"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07"
4SECTION = "console/network"
5SRCREV = "00dbec2636ae0385ad028587e20e446272ff97ec"
6PV = "1.1+gitr${SRCPV}"
7
Andrew Geissler595f6302022-01-24 19:11:47 +00008SRC_URI = "git://github.com/freesmartphone/cornucopia.git;protocol=https;branch=master"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009S = "${WORKDIR}/git/tools/serial_forward"
10
11inherit autotools native
12
13do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_IMAGE}"
14do_deploy() {
15 install -d ${DEPLOY_DIR_IMAGE}
16 install -m 0755 ${B}/src/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
17}
18
19addtask deploy before do_package after do_install