blob: b79fdb1a0b5b0c323912769d13f08dd0c3224b3a [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001SUMMARY = "Tools of dm-thin device-mapper"
2DESCRIPTION = "A suite of tools for manipulating the metadata of the dm-thin device-mapper target."
3HOMEPAGE = "https://github.com/jthornber/thin-provisioning-tools"
4LICENSE = "GPL-3.0-only"
5SECTION = "devel"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8S = "${WORKDIR}/git"
9
10SRC_URI = " \
11 git://github.com/jthornber/thin-provisioning-tools;branch=main;protocol=https \
12 "
Andrew Geissler8f840682023-07-21 09:09:43 -050013
Patrick Williams169d7bc2024-01-05 11:33:25 -060014SRCREV = "1d60839b0a920df6476712b80f933854fb32e160"
Andrew Geissler8f840682023-07-21 09:09:43 -050015UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
16
17inherit cargo cargo-update-recipe-crates
18
19require ${BPN}-crates.inc
20require ${BPN}-git-crates.inc
21
22do_install:append() {
23 for tool in cache_check \
24 cache_dump \
25 cache_metadata_size \
26 cache_repair \
27 cache_restore \
28 cache_writeback \
29 thin_check \
30 thin_delta \
31 thin_dump \
32 thin_ls \
33 thin_repair \
34 thin_restore \
35 thin_rmap \
36 thin_metadata_size \
37 thin_metadata_pack \
38 thin_metadata_unpack \
39 thin_trim \
40 era_check \
41 era_dump \
42 era_invalidate \
43 era_restore; do
44 ln -sf pdata_tools ${D}${bindir}/$tool
45 done
46}