blob: c8cfaa8aa31628d4c274f5a26ce4671f47e871bb [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "An implementation of RFC 7049 - Concise Binary Object Representation (CBOR)."
2DEPENDS +="${PYTHON_PN}-setuptools-scm-native"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7SRC_URI[sha256sum] = "f9e192f461a9f8f6082df28c035b006d153904213dc8640bed8a72d72bbc9475"
8
9inherit pypi python_setuptools_build_meta ptest
10
11DEPENDS += "python3-setuptools-scm-native"
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 ${PYTHON_PN}-hypothesis \
19 ${PYTHON_PN}-pytest \
20 ${PYTHON_PN}-unixadmin \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS:${PN} += " \
29 ${PYTHON_PN}-datetime \
30"
31
32BBCLASSEXTEND = "native nativesdk"