blob: c08aec5bece76cee281ab4dc876051eddbcc3bda [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Simplified object serialization in python"
2DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes."
Andrew Geissler517393d2023-01-13 08:55:19 -06003HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "\
Patrick Williams56b44a92024-01-19 08:49:29 -06006 file://LICENSE;md5=653847350fed2e0e7b02791a35b98d59 \
Andrew Geissler517393d2023-01-13 08:55:19 -06007 file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
8
Patrick Williams56b44a92024-01-19 08:49:29 -06009SRC_URI[sha256sum] = "4c1daff273513dc5eb24b219a8035559dc573c8f322558ef85f5438ddd1236dd"
Andrew Geissler517393d2023-01-13 08:55:19 -060010
Patrick Williams56b44a92024-01-19 08:49:29 -060011inherit setuptools3 pypi
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13PIP_INSTALL_PACKAGE = "marshmallow"
14
15RDEPENDS:${PN} += " \
16 python3-core \
17 python3-datetime \
18 python3-netclient \
19 python3-numbers \
20 python3-json \
21 python3-pprint \
22 python3-packaging \
23"