Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Simplified object serialization in python" |
| 2 | DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes." |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 3 | HOMEPAGE = "https://github.com/marshmallow-code/marshmallow" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "\ |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 6 | file://LICENSE;md5=653847350fed2e0e7b02791a35b98d59 \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 7 | file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb" |
| 8 | |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "4c1daff273513dc5eb24b219a8035559dc573c8f322558ef85f5438ddd1236dd" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 11 | inherit setuptools3 pypi |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | |
| 13 | PIP_INSTALL_PACKAGE = "marshmallow" |
| 14 | |
| 15 | RDEPENDS:${PN} += " \ |
| 16 | python3-core \ |
| 17 | python3-datetime \ |
| 18 | python3-netclient \ |
| 19 | python3-numbers \ |
| 20 | python3-json \ |
| 21 | python3-pprint \ |
| 22 | python3-packaging \ |
| 23 | " |