Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)" |
| 2 | LICENSE = "MIT" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=873757af01d2d221eedb422c4c1dd163" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 4 | DEPENDS = "python3-cython proj" |
| 5 | DEPENDS:append:class-target = " python3-cython-native proj-native" |
| 6 | |
| 7 | PYPI_PACKAGE = "pyproj" |
| 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "44aa7c704c2b7d8fb3d483bbf75af6cb2350d30a63b144279a09b75fead501bf" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 13 | RDEPENDS:${PN} = " \ |
| 14 | python3-certifi \ |
| 15 | python3-compression \ |
| 16 | python3-json \ |
| 17 | python3-logging \ |
| 18 | python3-profile \ |
| 19 | " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 20 | |
| 21 | export PROJ_INCDIR = "${STAGING_INCDIR}" |
| 22 | export PROJ_LIBDIR = "${STAGING_LIBDIR}" |
| 23 | export PROJ_DIR = "${STAGING_BINDIR_NATIVE}/.." |