Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Ultra fast JSON encoder and decoder for Python" |
| 2 | DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3." |
| 3 | |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e0039a83d8a99726b5418f0b03302d0a" |
| 6 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "89cc92e73d5501b8a7f48575eeb14ad27156ad092c2e9fc7e3cf949f07e75532" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 8 | |
| 9 | inherit pypi ptest setuptools3 |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | file://0001-setup.py-Do-not-strip-debugging-symbols.patch \ |
| 14 | " |
| 15 | |
| 16 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" |
| 17 | |
| 18 | RDEPENDS:${PN} += "\ |
| 19 | ${PYTHON_PN}-datetime \ |
| 20 | ${PYTHON_PN}-numbers \ |
| 21 | " |
| 22 | |
| 23 | RDEPENDS:${PN}-ptest += " \ |
| 24 | ${PYTHON_PN}-json \ |
| 25 | ${PYTHON_PN}-pytest \ |
| 26 | ${PYTHON_PN}-pytz \ |
| 27 | " |
| 28 | |
| 29 | do_install_ptest() { |
| 30 | install -d ${D}${PTEST_PATH}/tests |
| 31 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 32 | } |
| 33 | |
| 34 | BBCLASSEXTEND = "native nativesdk" |