blob: d9fe4c0c4c913ea26e1a895daf9dc9078f975c4b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
Andrew Geissler3eeda902023-05-19 10:14:02 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
Andrew Geissler517393d2023-01-13 08:55:19 -06005
Patrick Williams169d7bc2024-01-05 11:33:25 -06006SRC_URI[sha256sum] = "566db86717cf8080b99b58b083b773a908ae40f06681e87e589a976faf8246bf"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8SRC_URI += "file://run-ptest"
9
10PYPI_PACKAGE = "yarl"
11
Patrick Williams169d7bc2024-01-05 11:33:25 -060012inherit pypi ptest python_setuptools_build_meta
13
14DEPENDS += " \
15 ${PYTHON_PN}-expandvars-native \
16 ${PYTHON_PN}-cython-native \
17"
Andrew Geissler517393d2023-01-13 08:55:19 -060018
19RDEPENDS:${PN} = "\
20 ${PYTHON_PN}-multidict \
21 ${PYTHON_PN}-idna \
22 ${PYTHON_PN}-io \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 ${PYTHON_PN}-pytest \
27"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
32}