Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Library for solving packages and reading repositories" |
| 2 | HOMEPAGE = "https://github.com/openSUSE/libsolv" |
| 3 | BUGTRACKER = "https://github.com/openSUSE/libsolv/issues" |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8" |
| 7 | |
| 8 | DEPENDS = "expat zlib" |
| 9 | |
| 10 | SRC_URI = "git://github.com/openSUSE/libsolv.git \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 11 | " |
| 12 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 13 | SRCREV = "5205c5683ce2c8b8288534059ba40a318a2a161d" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | |
| 15 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit cmake |
| 20 | |
| 21 | PACKAGECONFIG ??= "rpm" |
| 22 | PACKAGECONFIG[rpm] = "-DENABLE_RPMMD=ON -DENABLE_RPMDB=ON,,rpm" |
| 23 | |
| 24 | EXTRA_OECMAKE = "-DMULTI_SEMANTICS=ON -DENABLE_COMPLEX_DEPS=ON" |
| 25 | |
| 26 | PACKAGES =+ "${PN}-tools ${PN}ext" |
| 27 | |
| 28 | FILES_${PN}-tools = "${bindir}/*" |
| 29 | FILES_${PN}ext = "${libdir}/${PN}ext.so.*" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |