blob: 87a1e665ca627925c9c1988ae7faff368c8ea1fc [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \
11 file://0001-docs-do-not-build-efisecdb-manpage.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000012 "
Patrick Williams520786c2023-06-25 16:20:36 -050013SRCREV = "90e88b221e8bc60dc50f3246051369b8f580c0d0"
14PV .= "+39+git${SRCPV}"
Andrew Geissler595f6302022-01-24 19:11:47 +000015
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20export CCLD_FOR_BUILD = "${BUILD_CCLD}"
21
22# Upstream uses --add-needed in gcc.specs which gold doesn't support, so
23# enforce BFD.
24LDFLAGS += "-fuse-ld=bfd"
25
26do_compile() {
27 oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}"
28}
29
30do_install() {
31 oe_runmake install DESTDIR=${D}
32}
33
34BBCLASSEXTEND = "native"
35
36RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs"
37
38CLEANBROKEN = "1"