blob: 36d35e6dee891f1d912df8f5e7035f52acb91dae [file] [log] [blame]
Andrew Geissler20137392023-10-12 04:59:14 -06001LICENSE = "GPL-2.0-only"
2LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
3
4SRC_URI = " \
5 http://www.litech.org/tayga/tayga-${PV}.tar.bz2 \
6 file://tayga.conf \
7 file://tayga.service \
8 file://0001-include-sys-uio.patch;striplevel=0 \
9 "
10SRC_URI[sha256sum] = "2b1f7927a9d2dcff9095aff3c271924b052ccfd2faca9588b277431a44f0009c"
11
12SYSTEMD_PACKAGES = "${PN}"
13SYSTEMD_SERVICE:${PN} = "tayga.service"
14
15do_install:append() {
16 install -m 0644 ${WORKDIR}/tayga.conf ${D}${sysconfdir}/tayga.conf
17 install -d ${D}${systemd_unitdir}/system/
18 install -m 0644 ${WORKDIR}/tayga.service ${D}${systemd_unitdir}/system/
19}
20
21inherit autotools systemd