Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Python bindings for GStreamer 1.0" |
| 2 | DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \ |
| 3 | provided by python-gi) " |
| 4 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/" |
| 5 | SECTION = "multimedia" |
| 6 | |
| 7 | LICENSE = "LGPL-2.1-or-later" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740" |
| 9 | |
| 10 | SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "99e37ea9f7163099734f9b0fce361bc67a0e7a65ffba9bc497127506a3fdedb3" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 12 | |
| 13 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" |
| 14 | RDEPENDS:${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" |
| 15 | |
| 16 | PNREAL = "gst-python" |
| 17 | |
| 18 | S = "${WORKDIR}/${PNREAL}-${PV}" |
| 19 | |
| 20 | EXTRA_OEMESON += "\ |
| 21 | -Dtests=disabled \ |
| 22 | -Dplugin=enabled \ |
| 23 | -Dlibpython-dir=${libdir} \ |
| 24 | " |
| 25 | |
| 26 | inherit meson pkgconfig setuptools3-base upstream-version-is-even features_check |
| 27 | |
| 28 | FILES:${PN} += "${libdir}/gstreamer-1.0" |
| 29 | |
| 30 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |